WSC Server neue PHP7 Funktion

  • Sehr geehrte ALL-INKL.COM - Kundin,
    Sehr geehrter ALL-INKL.COM - Kunde,


    im Zuge der Anpassung an aktuelle Versionen und zur Aufrechterhaltung eines modernen Serverstandards werden wir in den nächsten Monaten Updates der Software und des Betriebssystems aller Server durchführen.


    Einen festen Termin für die Umstellung können wir Ihnen noch nicht nennen, wir informieren Sie jedoch rechtzeitig, sobald dieser für Ihren Server feststeht. Die Information mit dem Termin erhalten Sie ab November 2016.


    Konkret sind folgende Änderungen geplant:


    (1) PHP-Umstellung


    Da die PHP-Versionen 5.2, 5.3 und 5.4 schon länger vom Hersteller nicht mehr unterstützt und weiterentwickelt werden, müssen auch wir die Unterstützung hierfür einstellen. Sollten noch Web-Anwendungen mit PHP 5.2, 5.3 oder 5.4 arbeiten, müssen diese Anwendungen, um eine weitere Funktionsfähigkeit zu gewährleisten, aktualisiert werden. Andernfalls erhalten Sie nach der Serverumstellung eine Fehlerausgabe.


    Um Ihnen eine damit verbundene, aufwendige Prüfung zu ersparen, stellen wir Ihnen in Ihrem Kundenadministrationssystem (KAS) ab sofort eine Übersicht zur Verfügung. In dieser sehen Sie, welche Domains, Ordner bzw. Dateien von der Abschaltung betroffen sind.


    Das KAS erreichen Sie unter: XXX


    Einige Hinweise zur PHP-Umstellung haben wir hier für Sie zusammengestellt: http://XXX


    (2) Aktualisierung des Betriebssystems


    Nach Abschluss der PHP-Umstellung, voraussichtlich ab dem 1. Quartal 2017, werden wir das auslaufende Betriebssystem Ubuntu 12.04 gegen Ubuntu 16.04 ersetzen. Mit dieser Umstellung werden wir auch die Unterstützung für Microsoft FrontPage einstellen, da dieses auf Ubuntu 16.04 nicht mehr lauffähig ist. Sollten Sie davon betroffen sein, werden wir Sie aber diesbezüglich noch einmal rechtzeitig anschreiben.


    WSC wird somit ab 2017 auf die neue PHP 7 Version umsteigen müssen und es sei möglich, dass Programmierungen wie Module nicht zur Verfügung stehen. Soweit wollen wir es nicht kommen lassen und versuchen bis dahin alle Systeme auf die neue PHP7 Version zu konfigurieren!


    Zu beachten sei, dass alle Server wie Webspace auf die PHP 7 Version umstellen werden und dies in allen Sims die diese HSE Software nutzten betroffen sein werden. Da in der Szene des Simgeschäft die HSE Software von Ingo Hofmann genutzt wird, sitzen wir alle im selben Boot und alle Betreiber sollten sich zusammen setzen, damit die Versionen auch in der Zukunft zur Szene weiter läuft !


    Das Forum dazu bleibt unberührt, da wir als WSC das neuste System nutzen und stetig Updates folgen !

  • Die momentan noch zur Nutzung angebotenen PHP-Versionen 5.2, 5.3 und 5.4 sind veraltet. Sicherheitsupdates sind für diese Versionen nicht oder nur noch kurz erhältlich. Bei Ihren Accounts wurden jedoch keinerlei Probleme festgestellt und Sie nutzen bereits aktuellere PHP Versionen. Sie müssen also nichts weiter unternehmen.


    Systemüberprüfung erfolgreich, was aber nicht bedeutet, dass man sich zurück lehnt. Die Zukunft schläft nicht und müssen weiter Up to Date sein !


    Nutzer, die aus dem FMZ Server Module beziehen, werde ich noch mal Rücksprache mit dem Programmierer suchen. Wie es mir bewusst war, sollten diese auch modernisiert geschrieben und funktionsfähig bleiben, denn wir hatten damals schon an die Zukunft gedacht. Info dazu erfolgt !

  • Die Abschaltung der PHP-Versionen 5.2, 5.3 und 5.4 für Ihren Server erfolgt am 17.01.2017 in der Zeit zwischen 08:00 und 17:00 Uhr.
    Der Server und damit auch Ihre Accounts bleiben währenddessen weiterhin erreichbar. Sie erhalten nach Abschluss der Arbeiten eine Bestätigung per E-Mail.


    Da wir von WSC als Check nicht betroffen sein werden, aktuell auch auf PHP 7+ laufen, sollten wir da keine Bedenken haben !!!

    Nur der WSC !!!

  • Sehr geehrte ALL-INKL.COM - Kundin,
    Sehr geehrter ALL-INKL.COM - Kunde,


    wie angekündigt haben wir die nicht mehr unterstützten PHP-Versionen 5.2, 5.3 und 5.4 auf Ihrem Server abgeschaltet.

    Sollten Sie auf Ihrer Webseite/Ihren Webseiten eine Meldung erhalten, dass die gewählte PHP Version auf dem Server nicht verfügbar ist, kontrollieren Sie bitte folgendes:

    - die gesetze PHP-Version im KAS (http://kas.all-inkl.com) unter "Domain". Diese kann durch einen Klick auf "Bearbeiten" auf eine aktuelle PHP-Version angepasst werden.

    - eventuelle Addhandler-Einträge in der .htaccess-Datei im Stammverzeichnis der Webseite (z.B.: AddHandler php54-cgi .php). Diese müssen auf eine aktuelle PHP-Version angepasst werden (z.B.: AddHandler php56-cgi .php)

    Bei Fragen steht Ihnen unser Support gern zur Verfügung.


    Habe das alles komplett schon seid Wochen angepasst, also wer ist ein Anfänger ? Ich nicht, wurde reibungslos wie ich sehe PHP 7 übernommen. Wenn ein User eine Fehlermeldung erhalten werde, bitte an PN an mich, mit der Meldung. Sollte eigentlich nicht vortreten, wenn doch, Meldung an PM an mich. Kümmere mich dann darum. Dienstleistung der Partners werde ich keinen Support geben, habe mehr im Kopf als Fehlerbehebungen andere Sims. Ist mehr Privatleben !!!